Skip to content

← Actionable
Medium, CVSS 5.5

Regular expression denial of service in apache tika

CVE-2022-30126GHSA-rpjm-422r-95mh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tika:tika-core 2.4.0, 1.28.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-30126: 2.60% estimated exploitation activity in the next 30 days; percentile 85.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Apache Tika, a regular expression in our StandardsText class, used by the StandardsExtractingContentHandler could lead to a denial of service caused by backtracking on a specially crafted file. This only affects users who are running the StandardsExtractingContentHandler, which is a non-standard handler. This was originally fixed in 1.28.2 and 2.4.0. While the fix in version 2.4.0 was complete, the fix for the 1.x branch wasn't incorporated until version 1.28.3. Please see GHSA-qw3f-w4pf-jh5f for more information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rpjm-422r-95mh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-30126

Advisory: Regular expression denial of service in apache tika
IDs: CVE-2022-30126, GHSA-rpjm-422r-95mh
Record: https://patchnext.com/advisories/cve-2022-30126 (revision 1, source checked 26 Oct 2026, 16:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tika:tika-core 2.4.0, 1.28.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tika:tika-core: affected >= 1.17, < 1.28.2; >= 2.0.0, < 2.4.0; fixed in 2.4.0, 1.28.2

## Suggested inspection (read-only)
- Maven org.apache.tika:tika-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tika:tika-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rpjm-422r-95mh (GitHub-reviewed advisory GHSA-rpjm-422r-95mh lists affected ranges: Maven org.apache.tika:tika-core >=1.17 =2.0.0 <2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…