Skip to content

← Actionable
High, CVSS 7.5

Denial of Service Vulnerability in Rack Multipart Parsing

CVE-2022-30122GHSA-hxqx-xwvh-44m2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 2.2.3.1, 2.1.4.1, 2.0.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rack

    Affected
    >= 1.2, <= 2.0.9.0>= 2.1, <= 2.1.4.0>= 2.2, <= 2.2.3.0
    Fixed in
    2.2.3.1, 2.1.4.1, 2.0.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-30122: 2.23% estimated exploitation activity in the next 30 days; percentile 82.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a possible denial of service vulnerability in the multipart parsing component of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-30122. Versions Affected: = 1.2 Not affected: < 1.2 Fixed Versions: 2.0.9.1, 2.1.4.1, 2.2.3.1 Impact Carefully crafted multipart POST requests can cause Rack's multipart parser to take much longer than expected, leading to a possible denial of service vulnerability. Impacted code will use Rack's multipart parser to parse multipart posts. This includes directly using the multipart parser like this: But it also includes reading POST data from a Rack request object like this: All users running an affected release should either upgrade or use one of the workarounds immediately. Workarounds There are no feasible workarounds for this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hxqx-xwvh-44m2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-30122

Advisory: Denial of Service Vulnerability in Rack Multipart Parsing
IDs: CVE-2022-30122, GHSA-hxqx-xwvh-44m2
Record: https://patchnext.com/advisories/cve-2022-30122 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack 2.2.3.1, 2.1.4.1, 2.0.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack: affected >= 1.2, <= 2.0.9.0; >= 2.1, <= 2.1.4.0; >= 2.2, <= 2.2.3.0; fixed in 2.2.3.1, 2.1.4.1, 2.0.9.1

## Suggested inspection (read-only)
- RubyGems rack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hxqx-xwvh-44m2 (GitHub-reviewed advisory GHSA-hxqx-xwvh-44m2 lists affected ranges: RubyGems rack >=1.2 =2.1 =2.2 <=2.2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…