Path traversal in Concrete CMS
CVE-2022-30117GHSA-3jxh-6635-6jwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (concrete5/core 9.1.0, 8.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist concrete5/core
- Affected
- >= 9.0.0, < 9.1.0< 8.5.8
- Fixed in
- 8.5.8, 9.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3jxh-6635-6jwp lists affected ranges: Packagist concrete5/core >=9.0.0 =0 <8.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2022-30117: 2.13% estimated exploitation activity in the next 30 days; percentile 81.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 allow traversal in /index.php/ccm/system/file/upload which could result in an Arbitrary File Delete exploit. This was remediated by sanitizing /index.php/ccm/system/file/upload to ensure Concrete doesn’t allow traversal and by changing isFullChunkFilePresent to have an early false return when input doesn't match expectations.Concrete CMS Security team ranked this 5.8 with CVSS v3.1 vector AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:N/A:H. Credit to Siebene for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3jxh-6635-6jwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-30117 Advisory: Path traversal in Concrete CMS IDs: CVE-2022-30117, GHSA-3jxh-6635-6jwp Record: https://patchnext.com/advisories/cve-2022-30117 (revision 1, source checked 26 Oct 2026, 14:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: concrete5/core 9.1.0, 8.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist concrete5/core: affected >= 9.0.0, < 9.1.0; < 8.5.8; fixed in 8.5.8, 9.1.0 ## Suggested inspection (read-only) - Packagist concrete5/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on concrete5/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3jxh-6635-6jwp (GitHub-reviewed advisory GHSA-3jxh-6635-6jwp lists affected ranges: Packagist concrete5/core >=9.0.0 =0 <8.5.8) Commands are suggestions: review each one before running it.
Loading voting…