Incorrect Implementation of Authentication Algorithm in OPCFoundation.NetStandard.Opc.Ua.Core
CVE-2022-29865GHSA-fvxf-r9fw-49pc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opcfoundation.netstandard.opc.ua.core 1.4.368.58), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet opcfoundation.netstandard.opc.ua.core
- Affected
- <= 1.4.368.53
- Fixed in
- 1.4.368.58
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fvxf-r9fw-49pc lists affected ranges: NuGet opcfoundation.netstandard.opc.ua.core >=0 <=1.4.368.53
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2022-29865: 1.62% estimated exploitation activity in the next 30 days; percentile 76.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was discovered in the OPC UA .NET Standard Stack that - allows a malicious client or server to bypass the application authentication mechanism - and allow a connection to an untrusted peer.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fvxf-r9fw-49pc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29865 Advisory: Incorrect Implementation of Authentication Algorithm in OPCFoundation.NetStandard.Opc.Ua.Core IDs: CVE-2022-29865, GHSA-fvxf-r9fw-49pc Record: https://patchnext.com/advisories/cve-2022-29865 (revision 1, source checked 26 Oct 2026, 16:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opcfoundation.netstandard.opc.ua.core 1.4.368.58. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet opcfoundation.netstandard.opc.ua.core: affected <= 1.4.368.53; fixed in 1.4.368.58 ## Suggested inspection (read-only) - NuGet opcfoundation.netstandard.opc.ua.core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opcfoundation.netstandard.opc.ua.core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fvxf-r9fw-49pc (GitHub-reviewed advisory GHSA-fvxf-r9fw-49pc lists affected ranges: NuGet opcfoundation.netstandard.opc.ua.core >=0 <=1.4.368.53) Commands are suggestions: review each one before running it.
Loading voting…