Skip to content

← Actionable
High, CVSS 8.7amended

Multiple evaluation of contract address in call in vyper

CVE-2022-29255GHSA-4v9q-cgpw-cf38

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    < 0.3.4
    Fixed in
    0.3.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-29255: 1.35% estimated exploitation activity in the next 30 days; percentile 71.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact when a calling an external contract with no return value, the contract address could be evaluated twice. this is usually only an efficiency problem, but if evaluation of the contract address has side effects, it could result in double evaluation of the side effects. in the following example, Foo(msg.sender).bar() is the contract address for the following call (to .foo()), and could get evaluated twice Patches 6b4d8ff185de071252feaa1c319712b2d6577f8d Workarounds assign contract addresses to variables. the above example would change to References For more information

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4v9q-cgpw-cf38

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4v9q-cgpw-cf38

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-29255

Advisory: Multiple evaluation of contract address in call in vyper
IDs: CVE-2022-29255, GHSA-4v9q-cgpw-cf38
Record: https://patchnext.com/advisories/cve-2022-29255 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected < 0.3.4; fixed in 0.3.4

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4v9q-cgpw-cf38 (OSV record GHSA-4v9q-cgpw-cf38 lists affected ranges: PyPI vyper >=0 <0.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-4v9q-cgpw-cf38 (GitHub-reviewed advisory GHSA-4v9q-cgpw-cf38 lists affected ranges: PyPI vyper >=0 <0.3.4)

Commands are suggestions: review each one before running it.

Loading voting…