Failed payment recorded has completed in Silverstripe Omnipay
CVE-2022-29254GHSA-48f2-m7jg-866x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/silverstripe-omnipay 3.2.1, 3.1.4, 3.0.2, 2.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/silverstripe-omnipay
- Affected
- < 2.5.2>= 3.0.0, < 3.0.2>= 3.1.0, < 3.1.4>= 3.2.0, < 3.2.1
- Fixed in
- 3.2.1, 3.0.2, 2.5.2, 3.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48f2-m7jg-866x lists affected ranges: Packagist silverstripe/silverstripe-omnipay >=0 =3.0.0 =3.1.0 =3.2.0 <3.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-29254: 0.68% estimated exploitation activity in the next 30 days; percentile 52.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact For a subset of Omnipay gateways (those that use intermediary states like isNotification() or isRedirect()), if the payment identifier or success URL is exposed it is possible for payments to be prematurely marked as completed without payment being taken. This is mitigated by the fact that most payment gateways hide this information from users, however some issuing banks offer flawed 3DSecure implementations that may inadvertently expose this data. Patches The following versions have been patched to fix this issue: - 2.5.2 - 3.0.2 - 3.1.4 - 3.2.1 Workarounds There are no known workarounds for this vulnerability. References N/A. For more information If you have any questions or comments about this advisory: Email us at security@silverstripe.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-48f2-m7jg-866x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29254 Advisory: Failed payment recorded has completed in Silverstripe Omnipay IDs: CVE-2022-29254, GHSA-48f2-m7jg-866x Record: https://patchnext.com/advisories/cve-2022-29254 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/silverstripe-omnipay 3.2.1, 3.1.4, 3.0.2, 2.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/silverstripe-omnipay: affected < 2.5.2; >= 3.0.0, < 3.0.2; >= 3.1.0, < 3.1.4; >= 3.2.0, < 3.2.1; fixed in 3.2.1, 3.0.2, 2.5.2, 3.1.4 ## Suggested inspection (read-only) - Packagist silverstripe/silverstripe-omnipay: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/silverstripe-omnipay. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-48f2-m7jg-866x (GitHub-reviewed advisory GHSA-48f2-m7jg-866x lists affected ranges: Packagist silverstripe/silverstripe-omnipay >=0 =3.0.0 =3.1.0 =3.2.0 <3.2.1) Commands are suggestions: review each one before running it.
Loading voting…