Compromised child renderer processes could obtain IPC access without nodeIntegrationInSubFrames being enabled
CVE-2022-29247GHSA-mq8j-3h7h-p8g7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 18.0.0-beta.6, 17.2.0, 16.2.6, 15.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- < 15.5.5>= 16.0.0, < 16.2.6>= 17.0.0, < 17.2.0>= 18.0.0-beta.1, <= 18.0.0-beta.5
- Fixed in
- 18.0.0-beta.6, 15.5.5, 17.2.0, 16.2.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mq8j-3h7h-p8g7 lists affected ranges: npm electron >=0 =16.0.0 =17.0.0 =18.0.0-beta.1 <18.0.0-beta.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mq8j-3h7h-p8g7 lists affected ranges: npm electron >=0 =16.0.0 =17.0.0 =18.0.0-beta.1 <=18.0.0-beta.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.2 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-29247: 1.09% estimated exploitation activity in the next 30 days; percentile 65.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability allows a renderer with JS execution to obtain access to a new renderer process with nodeIntegrationInSubFrames enabled which in turn allows effective access to ipcRenderer. Please note the misleadingly named nodeIntegrationInSubFrames option does not implicitly grant Node.js access rather it depends on the existing sandbox setting. If your application is sandboxed then nodeIntegrationInSubFrames just gives access to the sandboxed renderer APIs (which includes ipcRenderer). If your application then additionally exposes IPC messages without IPC senderFrame validation that perform privileged actions or return confidential data this access to ipcRenderer can in turn compromise your application / user even with the sandbox enabled. Patches This has been patched and the following Electron versions contain the fix: 18.0.0-beta.6 17.2.0 16.2.6 15.5.5 Workarounds Ensure that all IPC message handlers appropriately validate senderFrame as per our security tutorial…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mq8j-3h7h-p8g7
- Revision 1 · created ·
Published from osv record GHSA-mq8j-3h7h-p8g7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29247 Advisory: Compromised child renderer processes could obtain IPC access without nodeIntegrationInSubFrames being enabled IDs: CVE-2022-29247, GHSA-mq8j-3h7h-p8g7 Record: https://patchnext.com/advisories/cve-2022-29247 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 18.0.0-beta.6, 17.2.0, 16.2.6, 15.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected < 15.5.5; >= 16.0.0, < 16.2.6; >= 17.0.0, < 17.2.0; >= 18.0.0-beta.1, <= 18.0.0-beta.5; fixed in 18.0.0-beta.6, 15.5.5, 17.2.0, 16.2.6 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mq8j-3h7h-p8g7 (OSV record GHSA-mq8j-3h7h-p8g7 lists affected ranges: npm electron >=0 =16.0.0 =17.0.0 =18.0.0-beta.1 <18.0.0-beta.6 (fixed)) - Verified: https://github.com/advisories/GHSA-mq8j-3h7h-p8g7 (GitHub-reviewed advisory GHSA-mq8j-3h7h-p8g7 lists affected ranges: npm electron >=0 =16.0.0 =17.0.0 =18.0.0-beta.1 <=18.0.0-beta.5) Commands are suggestions: review each one before running it.
Loading voting…