Packing does not respect root-level ignore files in workspaces
CVE-2022-29244GHSA-hj9c-8jmm-8c52
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (npm 8.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm npm
- Affected
- >= 7.9.0, < 8.11.0
- Fixed in
- 8.11.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hj9c-8jmm-8c52 lists affected ranges: npm npm >=7.9.0 <8.11.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hj9c-8jmm-8c52 lists affected ranges: npm npm >=7.9.0 <8.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-29244: 4.00% estimated exploitation activity in the next 30 days; percentile 90.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact npm pack ignores root-level .gitignore & .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. --workspaces, --workspace=<name). Anyone who has run npm pack or npm publish with workspaces, as of v7.9.0 & v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include. Patch - Upgrade to the latest, patched version of npm (v8.11.0 or greater), run: npm i -g npm@latest - Node.js versions v16.15.1, v17.19.1 & v18.3.0 include the patched v8.11.0 version of npm Steps to take to see if you're impacted 1. Run npm publish --dry-run or npm pack with an npm version =7.9.0 & <8.11.0 inside the project's root directory using a workspace flag like: --workspaces or --workspace=<name (ex. npm pack --workspace=foo) 2. Check the output in your terminal which will list the package contents (note: tar -tvf <package-on-disk also works) 3. If you find that there are files included you did not expect, you…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hj9c-8jmm-8c52
- Revision 1 · created ·
Published from osv record GHSA-hj9c-8jmm-8c52
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29244 Advisory: Packing does not respect root-level ignore files in workspaces IDs: CVE-2022-29244, GHSA-hj9c-8jmm-8c52 Record: https://patchnext.com/advisories/cve-2022-29244 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: npm 8.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm npm: affected >= 7.9.0, < 8.11.0; fixed in 8.11.0 ## Suggested inspection (read-only) - `npm ls npm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on npm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hj9c-8jmm-8c52 (OSV record GHSA-hj9c-8jmm-8c52 lists affected ranges: npm npm >=7.9.0 <8.11.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hj9c-8jmm-8c52 (GitHub-reviewed advisory GHSA-hj9c-8jmm-8c52 lists affected ranges: npm npm >=7.9.0 <8.11.0) Commands are suggestions: review each one before running it.
Loading voting…