Jupyter server Token bruteforcing
CVE-2022-29241GHSA-q874-g24w-4q9g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.0.0a1, 1.17.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server
- Affected
- < 1.17.1>= 2.0.0a0, <= 2.0.0a0
- Fixed in
- 1.17.1, 2.0.0a1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q874-g24w-4q9g lists affected ranges: PyPI jupyter-server >=0 =2.0.0a0 <2.0.0a1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q874-g24w-4q9g lists affected ranges: PyPI jupyter-server >=0 =2.0.0a0 <=2.0.0a0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-29241: 0.99% estimated exploitation activity in the next 30 days; percentile 62.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affects: Notebook and Lab between 6.4.0?(potentially earlier) and 6.4.11 (currently latest). Jupyter Server <=1.16.0. If I am correct about the responsible code it will affect Jupyter-Server 1.17.0 and 2.0.0a0 as well. Description: If notebook server is started with a value of rootdir that contains the starting user's home directory, then the underlying REST API can be used to leak the access token assigned at start time by guessing/brute forcing the PID of the jupyter server. While this requires an authenticated user session, this url can be used from an xss payload (as in CVE-2021-32798) or from a hooked or otherwise compromised browser to leak this access token to a malicious third party. This token can be used along with the REST API to interact with Jupyter services/notebooks such as modifying or overwriting critical files, such as .bashrc or .ssh/authorizedkeys, allowing a malicious user to read potentially sensitive data and possibly gain control of the impacted system.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q874-g24w-4q9g
- Revision 1 · created ·
Published from osv record GHSA-q874-g24w-4q9g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29241 Advisory: Jupyter server Token bruteforcing IDs: CVE-2022-29241, GHSA-q874-g24w-4q9g Record: https://patchnext.com/advisories/cve-2022-29241 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.0.0a1, 1.17.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server: affected < 1.17.1; >= 2.0.0a0, <= 2.0.0a0; fixed in 1.17.1, 2.0.0a1 ## Suggested inspection (read-only) - `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q874-g24w-4q9g (OSV record GHSA-q874-g24w-4q9g lists affected ranges: PyPI jupyter-server >=0 =2.0.0a0 <2.0.0a1 (fixed)) - Verified: https://github.com/advisories/GHSA-q874-g24w-4q9g (GitHub-reviewed advisory GHSA-q874-g24w-4q9g lists affected ranges: PyPI jupyter-server >=0 =2.0.0a0 <=2.0.0a0) Commands are suggestions: review each one before running it.
Loading voting…