Token bruteforcing.
CVE-2022-29238GHSA-v7vq-3x77-87vg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (notebook 6.4.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI notebook
- Affected
- < 6.4.12
- Fixed in
- 6.4.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v7vq-3x77-87vg lists affected ranges: PyPI notebook >=0 <6.4.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v7vq-3x77-87vg lists affected ranges: PyPI notebook >=0 <6.4.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-29238: 1.16% estimated exploitation activity in the next 30 days; percentile 67.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Authenticated requests to the notebook server with ContentsManager.allowhidden = False only prevented listing the contents of hidden directories, not accessing individual hidden files or files in hidden directories (i.e. hidden files were 'hidden' but not 'inaccessible'). This could lead to notebook configurations allowing authenticated access to files that may reasonably be expected to be disallowed. Because fully authenticated requests are required, this is of relatively low impact. But if a server's root directory contains sensitive files whose only protection from the server is being hidden (e.g. ~/.ssh while serving $HOME), then any authenticated requests could access files if their names are guessable. Such contexts also necessarily have full access to the server and therefore execution permissions, which also generally grants access to all the same files. So this does not generally result in any privilege escalation or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v7vq-3x77-87vg
- Revision 1 · created ·
Published from osv record GHSA-v7vq-3x77-87vg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29238 Advisory: Token bruteforcing. IDs: CVE-2022-29238, GHSA-v7vq-3x77-87vg Record: https://patchnext.com/advisories/cve-2022-29238 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: notebook 6.4.12. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI notebook: affected < 6.4.12; fixed in 6.4.12 ## Suggested inspection (read-only) - `python -m pip show notebook`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on notebook. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v7vq-3x77-87vg (OSV record GHSA-v7vq-3x77-87vg lists affected ranges: PyPI notebook >=0 <6.4.12 (fixed)) - Verified: https://github.com/advisories/GHSA-v7vq-3x77-87vg (GitHub-reviewed advisory GHSA-v7vq-3x77-87vg lists affected ranges: PyPI notebook >=0 <6.4.12) Commands are suggestions: review each one before running it.
Loading voting…