Missing Cryptographic Step in cassproject
CVE-2022-29229GHSA-7qcx-4p32-qcmx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cassproject 1.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm cassproject
- Affected
- < 1.5.8
- Fixed in
- 1.5.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7qcx-4p32-qcmx lists affected ranges: npm cassproject >=0 <1.5.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7qcx-4p32-qcmx lists affected ranges: npm cassproject >=0 <1.5.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2022-29229: 0.35% estimated exploitation activity in the next 30 days; percentile 28.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact CaSS Library, (npm:cassproject) has a missing cryptographic step when storing cryptographic keys that can allow a server administrator access to an account’s cryptographic keys. This affects CaSS servers using standalone username/password authentication, which uses a method that expects e2e cryptographic security of authorization credentials. Patches The issue has been patched in 1.5.8, however, the vulnerable accounts are only resecured when the user next logs in using standalone authentication, as the data required to resecure the account is not available to the server. Workarounds The issue may be mitigated by using SSO or client side certificates to log in. Please note that SSO and client side certificate authentication does not have this expectation of no-knowledge credential access, and cryptographic keys are available to the server administrator. References There are no references at this time. For more information If you have any questions or comments about this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7qcx-4p32-qcmx
- Revision 1 · created ·
Published from osv record GHSA-7qcx-4p32-qcmx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29229 Advisory: Missing Cryptographic Step in cassproject IDs: CVE-2022-29229, GHSA-7qcx-4p32-qcmx Record: https://patchnext.com/advisories/cve-2022-29229 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cassproject 1.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm cassproject: affected < 1.5.8; fixed in 1.5.8 ## Suggested inspection (read-only) - `npm ls cassproject --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cassproject. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7qcx-4p32-qcmx (OSV record GHSA-7qcx-4p32-qcmx lists affected ranges: npm cassproject >=0 <1.5.8 (fixed)) - Verified: https://github.com/advisories/GHSA-7qcx-4p32-qcmx (GitHub-reviewed advisory GHSA-7qcx-4p32-qcmx lists affected ranges: npm cassproject >=0 <1.5.8) Commands are suggestions: review each one before running it.
Loading voting…