AttesterSlashing number overflow
CVE-2022-29219GHSA-cvj7-5f3c-9vg9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@chainsafe/lodestar 0.36.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.36.0
- Fixed in
- 0.36.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cvj7-5f3c-9vg9 lists affected ranges: npm @chainsafe/lodestar >=0 <0.36.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cvj7-5f3c-9vg9 lists affected ranges: npm @chainsafe/lodestar >=0 <0.36.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2022-29219: 1.34% estimated exploitation activity in the next 30 days; percentile 71.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Possible consensus split given maliciously-crafted AttesterSlashing or ProposerSlashing being included on-chain. Since we represent uint64 values as native javascript numbers, there is an issue when those variables with large (greater than 2^53) uint64 values are included on chain. In those cases, Lodestar may view valid AttesterSlashing or ProposerSlashing as invalid, due to rounding errors in large number values. This causes a consensus split, where Lodestar nodes are forked away from the main network. Similarly Lodestar may consider invalid ProposerSlashing as valid, thus including in proposed blocks that will be considered invalid by the network. Patches https://github.com/ChainSafe/lodestar/pull/3977 Workarounds Use BigInt to represent Slot and Epoch values in AttesterSlashing and ProposerSlashing objects. BigInt is too slow to be used in all Slot and Epoch cases, so we will carefully use BigInt just where necessary for consensus.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cvj7-5f3c-9vg9
- Revision 1 · created ·
Published from osv record GHSA-cvj7-5f3c-9vg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29219 Advisory: AttesterSlashing number overflow IDs: CVE-2022-29219, GHSA-cvj7-5f3c-9vg9 Record: https://patchnext.com/advisories/cve-2022-29219 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @chainsafe/lodestar 0.36.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @chainsafe/lodestar: affected < 0.36.0; fixed in 0.36.0 ## Suggested inspection (read-only) - `npm ls @chainsafe/lodestar --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @chainsafe/lodestar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cvj7-5f3c-9vg9 (OSV record GHSA-cvj7-5f3c-9vg9 lists affected ranges: npm @chainsafe/lodestar >=0 <0.36.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cvj7-5f3c-9vg9 (GitHub-reviewed advisory GHSA-cvj7-5f3c-9vg9 lists affected ranges: npm @chainsafe/lodestar >=0 <0.36.0) Commands are suggestions: review each one before running it.
Loading voting…