Code injection in saved_model_cli in TensorFlow
CVE-2022-29216GHSA-75c9-jrh4-79mc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.8.1, 2.7.2, 2.6.4; tensorflow-gpu 2.8.1, 2.7.2, 2.6.4; tensorflow-cpu 2.8.1, 2.7.2, 2.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
- Fixed in
- 2.8.1, 2.7.2, 2.6.4
PyPI tensorflow-gpu
- Affected
- < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
- Fixed in
- 2.8.1, 2.7.2, 2.6.4
PyPI tensorflow-cpu
- Affected
- < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
- Fixed in
- 2.8.1, 2.7.2, 2.6.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-75c9-jrh4-79mc lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-75c9-jrh4-79mc lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-29216: 0.55% estimated exploitation activity in the next 30 days; percentile 46.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact TensorFlow's savedmodelcli tool is vulnerable to a code injection: This can be used to open a reverse shell This is because the fix for CVE-2021-41228 was incomplete. Under certain code paths it still allows unsafe execution: This code path was maintained for compatibility reasons as we had several test cases where numpy expressions were used as arguments. However, given that the tool is always run manually, the impact of this is still not severe. We have now removed the safe=False argument, so all parsing is done withough calling eval. Patches We have patched the issue in GitHub commit c5da7af048611aa29e9382371f0aed5018516cac. The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-75c9-jrh4-79mc
- Revision 1 · created ·
Published from osv record GHSA-75c9-jrh4-79mc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29216 Advisory: Code injection in `saved_model_cli` in TensorFlow IDs: CVE-2022-29216, GHSA-75c9-jrh4-79mc Record: https://patchnext.com/advisories/cve-2022-29216 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.8.1, 2.7.2, 2.6.4; tensorflow-gpu 2.8.1, 2.7.2, 2.6.4; tensorflow-cpu 2.8.1, 2.7.2, 2.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4 - PyPI tensorflow-gpu: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4 - PyPI tensorflow-cpu: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-75c9-jrh4-79mc (OSV record GHSA-75c9-jrh4-79mc lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1 (fixed)) - Verified: https://github.com/advisories/GHSA-75c9-jrh4-79mc (GitHub-reviewed advisory GHSA-75c9-jrh4-79mc lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1) Commands are suggestions: review each one before running it.
Loading voting…