Skip to content

← Actionable
Medium, CVSS 6.1amended

URL Redirection to Untrusted Site ('Open Redirect') in next-auth

CVE-2022-29214GHSA-q2mx-j4x2-2h74

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 4.3.3, 3.29.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next-auth

    Affected
    < 3.29.3>= 4.0.0, < 4.3.3
    Fixed in
    4.3.3, 3.29.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-29214: 0.67% estimated exploitation activity in the next 30 days; percentile 52.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact We found that this vulnerability is present when the developer is implementing an OAuth 1 provider (by extension, it means Twitter, which is the only built-in provider using OAuth 1), but upgrading is still recommended. next-auth v3 users before version 3.29.3 are impacted. (We recommend upgrading to v4, as v3 is considered unmaintained. See our migration guide) next-auth v4 users before version 4.3.3 are impacted. Patches We've released patches for this vulnerability in: - v3 - 3.29.3 - v4 - 4.3.3 You can do: or or (This will update to the latest v4 version, but you can change latest to 3 if you want to stay on v3.) Workarounds If you are not able to upgrade for any reason, you can add the following configuration to your callbacks option: References This vulnerability was discovered right after https://github.com/nextauthjs/next-auth/security/advisories/GHSA-f9wg-5f46-cjmw was published and is very similar in nature. Read more about the callbacks.redirect option in the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q2mx-j4x2-2h74

  2. Revision 1 · created ·

    Published from osv record GHSA-q2mx-j4x2-2h74

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-29214

Advisory: URL Redirection to Untrusted Site ('Open Redirect') in next-auth
IDs: CVE-2022-29214, GHSA-q2mx-j4x2-2h74
Record: https://patchnext.com/advisories/cve-2022-29214 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next-auth 4.3.3, 3.29.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next-auth: affected < 3.29.3; >= 4.0.0, < 4.3.3; fixed in 4.3.3, 3.29.3

## Suggested inspection (read-only)
- `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q2mx-j4x2-2h74 (OSV record GHSA-q2mx-j4x2-2h74 lists affected ranges: npm next-auth >=0 =4.0.0 <4.3.3 (fixed))
- Verified: https://github.com/advisories/GHSA-q2mx-j4x2-2h74 (GitHub-reviewed advisory GHSA-q2mx-j4x2-2h74 lists affected ranges: npm next-auth >=0 =4.0.0 <4.3.3)

Commands are suggestions: review each one before running it.

Loading voting…