Skip to content

← Actionable
Medium, CVSS 5.5amended

Undefined behavior when users supply invalid resource handles

CVE-2022-29207GHSA-5wpj-c6f7-24x8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.8.1, 2.7.2, 2.6.4; tensorflow-gpu 2.8.1, 2.7.2, 2.6.4; tensorflow-cpu 2.8.1, 2.7.2, 2.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tensorflow

    Affected
    < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
    Fixed in
    2.8.1, 2.7.2, 2.6.4
  • PyPI tensorflow-gpu

    Affected
    < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
    Fixed in
    2.8.1, 2.7.2, 2.6.4
  • PyPI tensorflow-cpu

    Affected
    < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
    Fixed in
    2.8.1, 2.7.2, 2.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-29207: 0.33% estimated exploitation activity in the next 30 days; percentile 25.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Multiple TensorFlow operations misbehave in eager mode when the resource handle provided to them is invalid: In graph mode, it would have been impossible to perform these API calls, but migration to TF 2.x eager mode opened up this vulnerability. If the resource handle is empty, then a reference is bound to a null pointer inside TensorFlow codebase (various codepaths). This is undefined behavior. Patches We have patched the issue in GitHub commit a5b89cd68c02329d793356bda85d079e9e69b4e7 and GitHub commit dbdd98c37bc25249e8f288bd30d01e118a7b4498. The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by Hong Jin from Singapore…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5wpj-c6f7-24x8

  2. Revision 1 · created ·

    Published from osv record GHSA-5wpj-c6f7-24x8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-29207

Advisory: Undefined behavior when users supply invalid resource handles
IDs: CVE-2022-29207, GHSA-5wpj-c6f7-24x8
Record: https://patchnext.com/advisories/cve-2022-29207 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.8.1, 2.7.2, 2.6.4; tensorflow-gpu 2.8.1, 2.7.2, 2.6.4; tensorflow-cpu 2.8.1, 2.7.2, 2.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4
- PyPI tensorflow-gpu: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4
- PyPI tensorflow-cpu: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5wpj-c6f7-24x8 (OSV record GHSA-5wpj-c6f7-24x8 lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-5wpj-c6f7-24x8 (GitHub-reviewed advisory GHSA-5wpj-c6f7-24x8 lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1)

Commands are suggestions: review each one before running it.

Loading voting…