Missing validation causes denial of service via Conv3DBackpropFilterV2
CVE-2022-29204GHSA-hx9q-2mx4-m4pg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.8.1, 2.7.2, 2.6.4; tensorflow-gpu 2.8.1, 2.7.2, 2.6.4; tensorflow-cpu 2.8.1, 2.7.2, 2.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
- Fixed in
- 2.8.1, 2.7.2, 2.6.4
PyPI tensorflow-gpu
- Affected
- < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
- Fixed in
- 2.8.1, 2.7.2, 2.6.4
PyPI tensorflow-cpu
- Affected
- < 2.6.4>= 2.7.0, < 2.7.2>= 2.8.0, < 2.8.1
- Fixed in
- 2.8.1, 2.7.2, 2.6.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hx9q-2mx4-m4pg lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hx9q-2mx4-m4pg lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-29204: 0.35% estimated exploitation activity in the next 30 days; percentile 29.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The implementation of tf.rawops.UnsortedSegmentJoin does not fully validate the input arguments. This results in a CHECK-failure which can be used to trigger a denial of service attack: The code assumes numsegments is a positive scalar but there is no validation: Since this value is used to allocate the output tensor, a negative value would result in a CHECK-failure (assertion failure), as per TFSA-2021-198. Patches We have patched the issue in GitHub commit 84563f265f28b3c36a15335c8b005d405260e943 and GitHub commit 20cb18724b0bf6c09071a3f53434c4eec53cc147. The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported externally via a GitHub…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hx9q-2mx4-m4pg
- Revision 1 · created ·
Published from osv record GHSA-hx9q-2mx4-m4pg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29204 Advisory: Missing validation causes denial of service via `Conv3DBackpropFilterV2` IDs: CVE-2022-29204, GHSA-hx9q-2mx4-m4pg Record: https://patchnext.com/advisories/cve-2022-29204 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.8.1, 2.7.2, 2.6.4; tensorflow-gpu 2.8.1, 2.7.2, 2.6.4; tensorflow-cpu 2.8.1, 2.7.2, 2.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4 - PyPI tensorflow-gpu: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4 - PyPI tensorflow-cpu: affected < 2.6.4; >= 2.7.0, < 2.7.2; >= 2.8.0, < 2.8.1; fixed in 2.8.1, 2.7.2, 2.6.4 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hx9q-2mx4-m4pg (OSV record GHSA-hx9q-2mx4-m4pg lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hx9q-2mx4-m4pg (GitHub-reviewed advisory GHSA-hx9q-2mx4-m4pg lists affected ranges: PyPI tensorflow >=0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 =0 =2.7.0 =2.8.0 <2.8.1) Commands are suggestions: review each one before running it.
Loading voting…