Skip to content

← Actionable
High, CVSS 8.8

Access to Unix domain socket can lead to privileges escalation in Cilium

CVE-2022-29178GHSA-6p8v-8cq8-v2r3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.11.5, 1.10.11, 1.9.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-29178: 0.29% estimated exploitation activity in the next 30 days; percentile 21.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users with host file system access on a node and the privileges to run as group ID 1000 can gain access to the per node API of Cilium via Unix domain socket on the host where Cilium is running. If a malicious user is able to gain unprivileged access to a user corresponding to this group, then they can leverage this access to compromise the integrity as well as system availability on that host. Operating Systems that have unprivileged users not belonging the group ID 1000 are not affected by this vulnerability. Best practices for managing the secure deployment of Kubernetes clusters will typically limit the ability for a malicious user to deploy pods with access to this group or to access the host filesystem, and limit user access to the nodes for users belonging to this group. These best practices include (but are not limited to) enforcing Admission Control policies to limit the configuration of Kubernetes Pod hostPath and SecurityContext fields. Patches Cilium versions…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6p8v-8cq8-v2r3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-29178

Advisory: Access to Unix domain socket can lead to privileges escalation in Cilium
IDs: CVE-2022-29178, GHSA-6p8v-8cq8-v2r3
Record: https://patchnext.com/advisories/cve-2022-29178 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.11.5, 1.10.11, 1.9.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cilium/cilium: affected >= 1.11.0, < 1.11.5; >= 1.10.0, < 1.10.11; < 1.9.16; fixed in 1.11.5, 1.10.11, 1.9.16

## Suggested inspection (read-only)
- Go github.com/cilium/cilium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cilium/cilium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6p8v-8cq8-v2r3 (GitHub-reviewed advisory GHSA-6p8v-8cq8-v2r3 lists affected ranges: Go github.com/cilium/cilium >=1.11.0 =1.10.0 =0 <1.9.16)

Commands are suggestions: review each one before running it.

Loading voting…