Skip to content

← Actionable
Medium, CVSS 6.1amended

Cross-site Scripting in Auth0 Lock

CVE-2022-29172GHSA-7ww6-75fj-jcj7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0-lock 11.33.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-29172: 0.62% estimated exploitation activity in the next 30 days; percentile 49.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview In versions before and including 11.32.2, when the “additional signup fields” feature is configured, a malicious actor can inject invalidated HTML code into these additional fields, which is then stored in the service usermetdata payload (using the name property). Verification emails, when applicable, are generated using this metadata. It is therefor possible for an actor to craft a malicious link by injecting HTML, which is then rendered as the recipient's name within the delivered email template. Am I affected? You are impacted by this vulnerability if you are using auth0-lock version 11.32.2 or lower and are using the “additional signup fields” feature in your application. How to fix that? Upgrade to version 11.33.0. Will this update impact my users? Additional signup fields that have been added to the signup tab on Lock will have HTML tags stripped from user input from version 11.33.0 onwards. The user will not receive any validation warning or feedback, but backend data…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7ww6-75fj-jcj7

  2. Revision 1 · created ·

    Published from osv record GHSA-7ww6-75fj-jcj7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-29172

Advisory: Cross-site Scripting in Auth0 Lock
IDs: CVE-2022-29172, GHSA-7ww6-75fj-jcj7
Record: https://patchnext.com/advisories/cve-2022-29172 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: auth0-lock 11.33.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm auth0-lock: affected < 11.33.0; fixed in 11.33.0

## Suggested inspection (read-only)
- `npm ls auth0-lock --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on auth0-lock.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7ww6-75fj-jcj7 (OSV record GHSA-7ww6-75fj-jcj7 lists affected ranges: npm auth0-lock >=0 <11.33.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7ww6-75fj-jcj7 (GitHub-reviewed advisory GHSA-7ww6-75fj-jcj7 lists affected ranges: npm auth0-lock >=0 <11.33.0)

Commands are suggestions: review each one before running it.

Loading voting…