Untrusted users can modify some Pipeline libraries in Jenkins Pipeline: Deprecated Groovy Libraries Plugin
CVE-2022-29047GHSA-hh6f-6fp5-gfpv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins.workflow:workflow-cps-global-lib 566.vd0a, 2.21.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib
- Affected
- < 2.21.3>= 544.vff04fa68714d, <= 564.ve62a
- Fixed in
- 566.vd0a, 2.21.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hh6f-6fp5-gfpv lists affected ranges: Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib >=0 =544.vff04fa68714d <=564.ve62a
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2022-29047: 1.18% estimated exploitation activity in the next 30 days; percentile 67.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multibranch Pipelines by default limit who can change the Pipeline definition from the Jenkinsfile. This is useful for SCMs like GitHub: Jenkins can build content from users without commit access, but who can submit pull requests, without granting them the ability to modify the Pipeline definition. In that case, Jenkins will just use the Pipeline definition in the pull request’s destination branch instead. In Pipeline: Deprecated Groovy Libraries Plugin 564.ve62a4ebbe039 and earlier the same protection does not apply to uses of the library step with a retriever argument pointing to a library in the current build’s repository and branch (e.g., library(…, retriever: legacySCM(scm))). This allows attackers able to submit pull requests (or equivalent), but not able to commit directly to the configured SCM, to effectively change the Pipeline behavior by changing the library behavior in their pull request, even if the Pipeline is configured to not trust them. Pipeline: Deprecated Groovy…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hh6f-6fp5-gfpv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-29047 Advisory: Untrusted users can modify some Pipeline libraries in Jenkins Pipeline: Deprecated Groovy Libraries Plugin IDs: CVE-2022-29047, GHSA-hh6f-6fp5-gfpv Record: https://patchnext.com/advisories/cve-2022-29047 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins.workflow:workflow-cps-global-lib 566.vd0a, 2.21.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib: affected < 2.21.3; >= 544.vff04fa68714d, <= 564.ve62a; fixed in 566.vd0a, 2.21.3 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins.workflow:workflow-cps-global-lib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hh6f-6fp5-gfpv (GitHub-reviewed advisory GHSA-hh6f-6fp5-gfpv lists affected ranges: Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib >=0 =544.vff04fa68714d <=564.ve62a) Commands are suggestions: review each one before running it.
Loading voting…