OctoPrint vulnerable to Insufficient Session Expiration.
CVE-2022-2888GHSA-937f-qh3w-6g87
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- < 1.8.3
- Fixed in
- 1.8.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-937f-qh3w-6g87 lists affected ranges: PyPI octoprint >=0 <1.8.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-937f-qh3w-6g87 lists affected ranges: PyPI octoprint >=0 <1.8.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-2888: 0.30% estimated exploitation activity in the next 30 days; percentile 22.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists. This issue is fixed in version 1.8.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-937f-qh3w-6g87
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-937f-qh3w-6g87
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-2888 Advisory: OctoPrint vulnerable to Insufficient Session Expiration. IDs: CVE-2022-2888, GHSA-937f-qh3w-6g87 Record: https://patchnext.com/advisories/cve-2022-2888 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 1.8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected < 1.8.3; fixed in 1.8.3 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-937f-qh3w-6g87 (OSV record GHSA-937f-qh3w-6g87 lists affected ranges: PyPI octoprint >=0 <1.8.3 (fixed)) - Verified: https://github.com/advisories/GHSA-937f-qh3w-6g87 (GitHub-reviewed advisory GHSA-937f-qh3w-6g87 lists affected ranges: PyPI octoprint >=0 <1.8.3) Commands are suggestions: review each one before running it.
Loading voting…