Page Compare Reflected Cross-site Scripting (XSS) vulnerability
CVE-2022-28820GHSA-w5m2-299g-rff5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.adobe.acs:acs-aem-commons 5.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.adobe.acs:acs-aem-commons
- Affected
- < 5.2.0
- Fixed in
- 5.2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w5m2-299g-rff5 lists affected ranges: Maven com.adobe.acs:acs-aem-commons >=0 <5.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-28820: 1.06% estimated exploitation activity in the next 30 days; percentile 64.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in /apps/acs-commons/content/page-compare.html endpoint via the a and b GET parameters. User input submitted via these parameters is not validated or sanitized. An attacker must provide a link to someone with access to AEM Author, and could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. The exploitation of this issue requires user interaction in order to be successful. Patches This issue has been resolved in 5.2.0. Workarounds None References N/A For more information If you have any questions or comments about this advisory open an issue in acs-aem-commons. Credit This issue was discovered and reported by Black Lantern Security. https://hackerone.com/reports/1466020
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w5m2-299g-rff5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-28820 Advisory: Page Compare Reflected Cross-site Scripting (XSS) vulnerability IDs: CVE-2022-28820, GHSA-w5m2-299g-rff5 Record: https://patchnext.com/advisories/cve-2022-28820 (revision 1, source checked 26 Oct 2026, 15:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.adobe.acs:acs-aem-commons 5.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.adobe.acs:acs-aem-commons: affected < 5.2.0; fixed in 5.2.0 ## Suggested inspection (read-only) - Maven com.adobe.acs:acs-aem-commons: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.adobe.acs:acs-aem-commons. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w5m2-299g-rff5 (GitHub-reviewed advisory GHSA-w5m2-299g-rff5 lists affected ranges: Maven com.adobe.acs:acs-aem-commons >=0 <5.2.0) Commands are suggestions: review each one before running it.
Loading voting…