Skip to content

← Actionable
Critical, CVSS 9.8

CSV-Safe improperly filters special characters potentially leading to CSV injection

CVE-2022-28481GHSA-f55g-x8qq-2569

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (csv-safe 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems csv-safe

    Affected
    < 3.0.0
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-28481: 1.76% estimated exploitation activity in the next 30 days; percentile 77.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CSV-Safe gem < 3.0.0 doesn't filter out special characters which could trigger CSV Injection.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f55g-x8qq-2569

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-28481

Advisory: CSV-Safe improperly filters special characters potentially leading to CSV injection
IDs: CVE-2022-28481, GHSA-f55g-x8qq-2569
Record: https://patchnext.com/advisories/cve-2022-28481 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: csv-safe 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems csv-safe: affected < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- RubyGems csv-safe: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on csv-safe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f55g-x8qq-2569 (GitHub-reviewed advisory GHSA-f55g-x8qq-2569 lists affected ranges: RubyGems csv-safe >=0 <3.0.0)

Commands are suggestions: review each one before running it.

Loading voting…