Arbitrary file read vulnerability in Jenkins Continuous Integration with Toad Edge Plugin
CVE-2022-28146GHSA-8p4x-fq8v-xhv4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:ci-with-toad-edge 2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:ci-with-toad-edge
- Affected
- < 2.4
- Fixed in
- 2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8p4x-fq8v-xhv4 lists affected ranges: Maven org.jenkins-ci.plugins:ci-with-toad-edge >=0 <2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-28146: 1.84% estimated exploitation activity in the next 30 days; percentile 78.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Continuous Integration with Toad Edge Plugin 2.3 and earlier allows attackers with Item/Configure permission to read arbitrary files on the Jenkins controller by specifying an input folder on the Jenkins controller as a parameter to its build steps.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8p4x-fq8v-xhv4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-28146 Advisory: Arbitrary file read vulnerability in Jenkins Continuous Integration with Toad Edge Plugin IDs: CVE-2022-28146, GHSA-8p4x-fq8v-xhv4 Record: https://patchnext.com/advisories/cve-2022-28146 (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:ci-with-toad-edge 2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:ci-with-toad-edge: affected < 2.4; fixed in 2.4 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:ci-with-toad-edge: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:ci-with-toad-edge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8p4x-fq8v-xhv4 (GitHub-reviewed advisory GHSA-8p4x-fq8v-xhv4 lists affected ranges: Maven org.jenkins-ci.plugins:ci-with-toad-edge >=0 <2.4) Commands are suggestions: review each one before running it.
Loading voting…