Skip to content

← Actionable
High, CVSS 8.8amended

Selenium Server (Grid) CSRF

CVE-2022-28108GHSA-h2rr-m97p-6jq9

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.seleniumhq.selenium:selenium-server

    Affected
    <= 4.0.0-alpha-2
    Fixed in
    no fixed version recorded
  • PyPI selenium

    Affected
    < 4.0.0
    Fixed in
    4.0.0
  • Maven org.seleniumhq.selenium:selenium-grid

    Affected
    < 4.0.0-alpha-7
    Fixed in
    4.0.0-alpha-7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-28108: 22.54% estimated exploitation activity in the next 30 days; percentile 97.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Selenium Server (Grid) before 4.0.0-alpha-7 allows CSRF because it permits non-JSON content types such as application/x-www-form-urlencoded, multipart/form-data, and text/plain.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h2rr-m97p-6jq9

  2. Revision 1 · created ·

    Published from osv record PYSEC-2022-43167

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-28108

Advisory: Selenium Server (Grid) CSRF
IDs: CVE-2022-28108, GHSA-h2rr-m97p-6jq9
Record: https://patchnext.com/advisories/cve-2022-28108 (revision 2, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: selenium 4.0.0; org.seleniumhq.selenium:selenium-grid 4.0.0-alpha-7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.seleniumhq.selenium:selenium-server: affected <= 4.0.0-alpha-2
- PyPI selenium: affected < 4.0.0; fixed in 4.0.0
- Maven org.seleniumhq.selenium:selenium-grid: affected < 4.0.0-alpha-7; fixed in 4.0.0-alpha-7

## Suggested inspection (read-only)
- Maven org.seleniumhq.selenium:selenium-server: check the installed version with your package manager.
- `python -m pip show selenium`: prints the installed version. Run with the environment that serves production active.
- Maven org.seleniumhq.selenium:selenium-grid: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.seleniumhq.selenium:selenium-server, selenium, org.seleniumhq.selenium:selenium-grid.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/PYSEC-2022-43167 (OSV record PYSEC-2022-43167 lists affected ranges: PyPI selenium >=0 <4.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h2rr-m97p-6jq9 (GitHub-reviewed advisory GHSA-h2rr-m97p-6jq9 lists affected ranges: Maven org.seleniumhq.selenium:selenium-grid >=0 =0 <=4.0.0-alpha-2)

Commands are suggestions: review each one before running it.

Loading voting…