Agent-to-controller security bypass in Jenkins Semantic Versioning Plugin
CVE-2022-27201GHSA-x3m3-g8w6-mf28
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:semantic-versioning-plugin 1.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:semantic-versioning-plugin
- Affected
- < 1.14
- Fixed in
- 1.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x3m3-g8w6-mf28 lists affected ranges: Maven org.jenkins-ci.plugins:semantic-versioning-plugin >=0 <1.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2022-27201: 1.40% estimated exploitation activity in the next 30 days; percentile 72.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Semantic Versioning Plugin defines a controller/agent message that processes a given file as XML and returns version information. The XML parser is not configured to prevent XML external entity (XXE) attacks, which is only a problem if XML documents are parsed on the Jenkins controller. Jenkins Semantic Versioning Plugin 1.13 and earlier does not restrict execution of a controller/agent message to agents, and implements no limitations about the file path that can be parsed, allowing attackers able to control agent processes to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery. This vulnerability is only exploitable in Jenkins 2.318 and earlier, LTS 2.303.2 and earlier. See the LTS upgrade guide.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x3m3-g8w6-mf28
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-27201 Advisory: Agent-to-controller security bypass in Jenkins Semantic Versioning Plugin IDs: CVE-2022-27201, GHSA-x3m3-g8w6-mf28 Record: https://patchnext.com/advisories/cve-2022-27201 (revision 1, source checked 26 Oct 2026, 16:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:semantic-versioning-plugin 1.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:semantic-versioning-plugin: affected < 1.14; fixed in 1.14 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:semantic-versioning-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:semantic-versioning-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x3m3-g8w6-mf28 (GitHub-reviewed advisory GHSA-x3m3-g8w6-mf28 lists affected ranges: Maven org.jenkins-ci.plugins:semantic-versioning-plugin >=0 <1.14) Commands are suggestions: review each one before running it.
Loading voting…