Skip to content

← Actionable
Low, CVSS 3.3

Sensitive parameter values captured in build metadata files by Jenkins Parameterized Trigger Plugin

CVE-2022-27195GHSA-5mpf-hw8f-86w9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:parameterized-trigger 2.43.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2022-27195: 0.38% estimated exploitation activity in the next 30 days; percentile 32.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Parameterized Trigger Plugin 2.43 and earlier captures environment variables passed to builds triggered using Jenkins Parameterized Trigger Plugin, including password parameter values, in their build.xml files. These values are stored unencrypted and can be viewed by users with access to the Jenkins controller file system. Existing build.xml files are not automatically updated to remove captured environment variables. They need to be manually cleaned up. To help with this, the plugin will report environment variables stored in build.xml as unloadable data in the Old Data Monitor, that allows discarding this data. Build records are only loaded from disk when needed however, so some builds stored in Jenkins may not immediately appear there.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5mpf-hw8f-86w9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-27195

Advisory: Sensitive parameter values captured in build metadata files by Jenkins Parameterized Trigger Plugin
IDs: CVE-2022-27195, GHSA-5mpf-hw8f-86w9
Record: https://patchnext.com/advisories/cve-2022-27195 (revision 1, source checked 26 Oct 2026, 16:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:parameterized-trigger 2.43.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:parameterized-trigger: affected < 2.43.1; fixed in 2.43.1

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:parameterized-trigger: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:parameterized-trigger.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5mpf-hw8f-86w9 (GitHub-reviewed advisory GHSA-5mpf-hw8f-86w9 lists affected ranges: Maven org.jenkins-ci.plugins:parameterized-trigger >=0 <2.43.1)

Commands are suggestions: review each one before running it.

Loading voting…