Insecure default value for CORS configuration
CVE-2022-26969GHSA-g27j-74fp-xfpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 9.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- < 9.7.0
- Fixed in
- 9.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g27j-74fp-xfpr lists affected ranges: npm directus >=0 <9.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g27j-74fp-xfpr lists affected ranges: npm directus >=0 <9.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-26969: 1.00% estimated exploitation activity in the next 30 days; percentile 62.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The default value for the CORSENABLED and CORSORIGIN configuration was set to be very permissive by default. This could lead to unauthorized access in uncontrolled environments when the configuration hasn't been changed. Patches The default values for CORS have been changed in https://github.com/directus/directus/pull/12022 which is released under 9.7.0 Workarounds Configure the CORS environment variables to match your project's usage, rather than leaving them at the (permissive) defaults. For more information If you have any questions or comments about this advisory: Open an issue in directus/directus Email us at security@directus.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g27j-74fp-xfpr
- Revision 1 · created ·
Published from osv record GHSA-g27j-74fp-xfpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-26969 Advisory: Insecure default value for CORS configuration IDs: CVE-2022-26969, GHSA-g27j-74fp-xfpr Record: https://patchnext.com/advisories/cve-2022-26969 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 9.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected < 9.7.0; fixed in 9.7.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g27j-74fp-xfpr (OSV record GHSA-g27j-74fp-xfpr lists affected ranges: npm directus >=0 <9.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-g27j-74fp-xfpr (GitHub-reviewed advisory GHSA-g27j-74fp-xfpr lists affected ranges: npm directus >=0 <9.7.0) Commands are suggestions: review each one before running it.
Loading voting…