Skip to content

← Actionable
High, CVSS 7.5

YARP Denial of Service Vulnerability

CVE-2022-26924GHSA-8xc6-g8xw-h2c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yarp.reverseproxy 1.1.0-rc.1.22211.2, 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet yarp.reverseproxy

    Affected
    < 1.0.1>= 1.1.0-rc.1.22152.1, <= 1.1.0-rc.1.22152.1
    Fixed in
    1.0.1, 1.1.0-rc.1.22211.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-26924: 3.51% estimated exploitation activity in the next 30 days; percentile 89.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial of service vulnerability exists in how YARP processes input. Patches If you're using YARP 1.0.0, you should update to NuGet package version 1.0.1. If you're using YARP 1.1.0-RC.1, you should update to NuGet package version 1.1.0-rc.1.22211.2. You can do so by updating the PackageReference in your .csproj file or by selecting 1.0.1 in the NuGet UI inside Visual Studio (Manage NuGet Packages / Updates) References CVE-2022-26924

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8xc6-g8xw-h2c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-26924

Advisory: YARP Denial of Service Vulnerability
IDs: CVE-2022-26924, GHSA-8xc6-g8xw-h2c4
Record: https://patchnext.com/advisories/cve-2022-26924 (revision 1, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yarp.reverseproxy 1.1.0-rc.1.22211.2, 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet yarp.reverseproxy: affected < 1.0.1; >= 1.1.0-rc.1.22152.1, <= 1.1.0-rc.1.22152.1; fixed in 1.0.1, 1.1.0-rc.1.22211.2

## Suggested inspection (read-only)
- NuGet yarp.reverseproxy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yarp.reverseproxy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8xc6-g8xw-h2c4 (GitHub-reviewed advisory GHSA-8xc6-g8xw-h2c4 lists affected ranges: NuGet yarp.reverseproxy >=0 =1.1.0-rc.1.22152.1 <=1.1.0-rc.1.22152.1)

Commands are suggestions: review each one before running it.

Loading voting…