Skip to content

← Actionable
High, CVSS 7.5

Apache Dolphin Scheduler has insufficiently protected credentials

CVE-2022-26885GHSA-jvc3-wjf6-7c6c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.dolphinscheduler:dolphinscheduler-common 2.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-26885: 1.36% estimated exploitation activity in the next 30 days; percentile 71.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jvc3-wjf6-7c6c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-26885

Advisory: Apache Dolphin Scheduler has insufficiently protected credentials
IDs: CVE-2022-26885, GHSA-jvc3-wjf6-7c6c
Record: https://patchnext.com/advisories/cve-2022-26885 (revision 1, source checked 26 Oct 2026, 16:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.dolphinscheduler:dolphinscheduler-common 2.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.dolphinscheduler:dolphinscheduler-common: affected < 2.0.6; fixed in 2.0.6

## Suggested inspection (read-only)
- Maven org.apache.dolphinscheduler:dolphinscheduler-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.dolphinscheduler:dolphinscheduler-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jvc3-wjf6-7c6c (GitHub-reviewed advisory GHSA-jvc3-wjf6-7c6c lists affected ranges: Maven org.apache.dolphinscheduler:dolphinscheduler-common >=0 <2.0.6)

Commands are suggestions: review each one before running it.

Loading voting…