Path traversal in org.postgresql:postgresql
CVE-2022-26520GHSA-727h-hrw8-jg8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.postgresql:postgresql 42.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.postgresql:postgresql
- Affected
- >= 42.1.0, < 42.3.3
- Fixed in
- 42.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-727h-hrw8-jg8q lists affected ranges: Maven org.postgresql:postgresql >=42.1.0 <42.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2022-26520: 3.00% estimated exploitation activity in the next 30 days; percentile 87.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In pgjdbc before 42.3.3, an attacker (who controls the jdbc URL or properties) can call java.util.logging.FileHandler to write to arbitrary files through the loggerFile and loggerLevel connection properties. An example situation is that an attacker could create an executable JSP file under a Tomcat web root. NOTE: the vendor's position is that there is no pgjdbc vulnerability; instead, it is a vulnerability for any application to use the pgjdbc driver with untrusted connection properties.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-727h-hrw8-jg8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-26520 Advisory: Path traversal in org.postgresql:postgresql IDs: CVE-2022-26520, GHSA-727h-hrw8-jg8q Record: https://patchnext.com/advisories/cve-2022-26520 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.postgresql:postgresql 42.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.postgresql:postgresql: affected >= 42.1.0, < 42.3.3; fixed in 42.3.3 ## Suggested inspection (read-only) - Maven org.postgresql:postgresql: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.postgresql:postgresql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-727h-hrw8-jg8q (GitHub-reviewed advisory GHSA-727h-hrw8-jg8q lists affected ranges: Maven org.postgresql:postgresql >=42.1.0 <42.3.3) Commands are suggestions: review each one before running it.
Loading voting…