Skip to content

← Actionable
High, CVSS 8.7amended

SystemDS CPU exhaustion vulnerability

CVE-2022-26477GHSA-m43h-hfrq-x8wx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (systemds 2.2.2; org.apache.systemds:systemds 2.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-26477: 2.25% estimated exploitation activity in the next 30 days; percentile 82.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Security Team noticed that the termination condition of the for loop in the readExternal method is a controllable variable, which, if tampered with, may lead to CPU exhaustion. As a fix, we added an upper bound and termination condition in the read and write logic. We classify it as a "low-priority but useful improvement". SystemDS is a distributed system and needs to serialize/deserialize data but in many code paths (e.g., on Spark broadcast/shuffle or writing to sequence files) the byte stream is anyway protected by additional CRC fingerprints. In this particular case though, the number of decoders is upper-bounded by twice the number of columns, which means an attacker would need to modify two entries in the byte stream in a consistent manner. By adding these checks robustness was strictly improved with almost zero overhead. These code changes are available in versions higher than 2.2.1.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m43h-hfrq-x8wx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m43h-hfrq-x8wx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-26477

Advisory: SystemDS CPU exhaustion vulnerability
IDs: CVE-2022-26477, GHSA-m43h-hfrq-x8wx
Record: https://patchnext.com/advisories/cve-2022-26477 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: systemds 2.2.2; org.apache.systemds:systemds 2.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI systemds: affected < 2.2.2; fixed in 2.2.2
- Maven org.apache.systemds:systemds: affected < 2.2.2; fixed in 2.2.2

## Suggested inspection (read-only)
- `python -m pip show systemds`: prints the installed version. Run with the environment that serves production active.
- Maven org.apache.systemds:systemds: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on systemds, org.apache.systemds:systemds.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m43h-hfrq-x8wx (OSV record GHSA-m43h-hfrq-x8wx lists affected ranges: Maven org.apache.systemds:systemds >=0 =0 <2.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-m43h-hfrq-x8wx (GitHub-reviewed advisory GHSA-m43h-hfrq-x8wx lists affected ranges: Maven org.apache.systemds:systemds >=0 =0 <2.2.2)

Commands are suggestions: review each one before running it.

Loading voting…