Skip to content

← Actionable
Critical, CVSS 9.3amended

Poetry before v1.1.9 contains Untrusted Search Path

CVE-2022-26184GHSA-xr2c-5w89-63pv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (poetry 1.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI poetry

    Affected
    < 1.1.9
    Fixed in
    1.1.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-26184: 1.85% estimated exploitation activity in the next 30 days; percentile 79.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Poetry prior to v1.1.9 was discovered to contain an untrusted search path which causes the application to behave in unexpected ways when users execute Poetry commands in a directory containing malicious content. This vulnerability occurs when the application is ran on Windows OS.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-xr2c-5w89-63pv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-xr2c-5w89-63pv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-26184

Advisory: Poetry before v1.1.9 contains Untrusted Search Path
IDs: CVE-2022-26184, GHSA-xr2c-5w89-63pv
Record: https://patchnext.com/advisories/cve-2022-26184 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: poetry 1.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI poetry: affected < 1.1.9; fixed in 1.1.9

## Suggested inspection (read-only)
- `python -m pip show poetry`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on poetry.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xr2c-5w89-63pv (OSV record GHSA-xr2c-5w89-63pv lists affected ranges: PyPI poetry >=0 <1.1.9 (fixed))
- Verified: https://github.com/advisories/GHSA-xr2c-5w89-63pv (GitHub-reviewed advisory GHSA-xr2c-5w89-63pv lists affected ranges: PyPI poetry >=0 <1.1.9)

Commands are suggestions: review each one before running it.

Loading voting…