Apache Pinot has Groovy Function support enabled by default
CVE-2022-26112GHSA-qj9p-jvmw-82rh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.pinot:pinot 0.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.pinot:pinot
- Affected
- < 0.11.0
- Fixed in
- 0.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qj9p-jvmw-82rh lists affected ranges: Maven org.apache.pinot:pinot >=0 <0.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-26112: 1.64% estimated exploitation activity in the next 30 days; percentile 76.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pinot allows you to run any function using Apache Groovy scripts. In versions prior to 0.10.0, Pinot query endpoint and realtime ingestion layer has a vulnerability in unprotected environments due to groovy function support being enabled by default. This issue has been fixed by making function support disabled by default, in version 0.11.0. A potential workaround is to disable groovy script support.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qj9p-jvmw-82rh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-26112 Advisory: Apache Pinot has Groovy Function support enabled by default IDs: CVE-2022-26112, GHSA-qj9p-jvmw-82rh Record: https://patchnext.com/advisories/cve-2022-26112 (revision 1, source checked 26 Oct 2026, 16:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.pinot:pinot 0.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.pinot:pinot: affected < 0.11.0; fixed in 0.11.0 ## Suggested inspection (read-only) - Maven org.apache.pinot:pinot: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.pinot:pinot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qj9p-jvmw-82rh (GitHub-reviewed advisory GHSA-qj9p-jvmw-82rh lists affected ranges: Maven org.apache.pinot:pinot >=0 <0.11.0) Commands are suggestions: review each one before running it.
Loading voting…