Goomph before 3.37.2 allows malicious zip file to write contents to arbitrary locations
CVE-2022-26049GHSA-p2f7-9cv7-jjf6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.diffplug.gradle:goomph 3.37.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.diffplug.gradle:goomph
- Affected
- < 3.37.2
- Fixed in
- 3.37.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p2f7-9cv7-jjf6 lists affected ranges: Maven com.diffplug.gradle:goomph >=0 <3.37.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-26049: 2.48% estimated exploitation activity in the next 30 days; percentile 84.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package com.diffplug.gradle:goomph before 3.37.2. It allows a malicious zip file to potentially break out of the expected destination directory, writing contents into arbitrary locations on the file system. Overwriting certain files/directories could allow an attacker to achieve remote code execution on a target system by exploiting this vulnerability. Note: This could have allowed a malicious zip file to extract itself into an arbitrary directory. The only file that Goomph extracts is the p2 bootstrapper and eclipse metadata files hosted at eclipse.org, which are not malicious, so the only way this vulnerability could have affected you is if you had set a custom bootstrap zip, and that zip was malicious.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p2f7-9cv7-jjf6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-26049 Advisory: Goomph before 3.37.2 allows malicious zip file to write contents to arbitrary locations IDs: CVE-2022-26049, GHSA-p2f7-9cv7-jjf6 Record: https://patchnext.com/advisories/cve-2022-26049 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.diffplug.gradle:goomph 3.37.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.diffplug.gradle:goomph: affected < 3.37.2; fixed in 3.37.2 ## Suggested inspection (read-only) - Maven com.diffplug.gradle:goomph: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.diffplug.gradle:goomph. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p2f7-9cv7-jjf6 (GitHub-reviewed advisory GHSA-p2f7-9cv7-jjf6 lists affected ranges: Maven com.diffplug.gradle:goomph >=0 <3.37.2) Commands are suggestions: review each one before running it.
Loading voting…