Skip to content

← Actionable
High, CVSS 7.5amended

ReDoS Vulnerability in ua-parser-js version

CVE-2022-25927GHSA-fhg7-m89q-25r3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ua-parser-js 1.0.33, 0.7.33), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ua-parser-js

    Affected
    >= 0.8.0, < 1.0.33>= 0.7.30, < 0.7.33
    Fixed in
    0.7.33, 1.0.33

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-25927: 1.73% estimated exploitation activity in the next 30 days; percentile 77.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description: A regular expression denial of service (ReDoS) vulnerability has been discovered in ua-parser-js. Impact: This vulnerability bypass the library's MAXLENGTH input limit prevention. By crafting a very-very-long user-agent string with specific pattern, an attacker can turn the script to get stuck processing for a very long time which results in a denial of service (DoS) condition. Affected Versions: From version 0.7.30 to before versions 0.7.33 / 1.0.33. Patches: A patch has been released to remove the vulnerable regular expression, update to version 0.7.33 / 1.0.33 or later. References: Regular expression Denial of Service - ReDoS Credits: Thanks to @Snyk who first reported the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fhg7-m89q-25r3

  2. Revision 1 · created ·

    Published from osv record GHSA-fhg7-m89q-25r3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25927

Advisory: ReDoS Vulnerability in ua-parser-js version
IDs: CVE-2022-25927, GHSA-fhg7-m89q-25r3
Record: https://patchnext.com/advisories/cve-2022-25927 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ua-parser-js 1.0.33, 0.7.33. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ua-parser-js: affected >= 0.8.0, < 1.0.33; >= 0.7.30, < 0.7.33; fixed in 0.7.33, 1.0.33

## Suggested inspection (read-only)
- `npm ls ua-parser-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ua-parser-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fhg7-m89q-25r3 (OSV record GHSA-fhg7-m89q-25r3 lists affected ranges: npm ua-parser-js >=0.7.30 =0.8.0 <1.0.33 (fixed))
- Verified: https://github.com/advisories/GHSA-fhg7-m89q-25r3 (GitHub-reviewed advisory GHSA-fhg7-m89q-25r3 lists affected ranges: npm ua-parser-js >=0.8.0 =0.7.30 <0.7.33)

Commands are suggestions: review each one before running it.

Loading voting…