Inefficient Regular Expression Complexity in shescape
CVE-2022-25918GHSA-cr84-xvw4-qx3c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shescape 1.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm shescape
- Affected
- >= 1.5.10, < 1.6.1
- Fixed in
- 1.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cr84-xvw4-qx3c lists affected ranges: npm shescape >=1.5.10 <1.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cr84-xvw4-qx3c lists affected ranges: npm shescape >=1.5.10 <1.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-25918: 1.63% estimated exploitation activity in the next 30 days; percentile 76.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This impacts users that use shescape to escape arguments: - for the Unix shell Bash, or any not-officially-supported Unix shell; - using the escape or escapeAll functions with the interpolation option set to true. An attacker can cause polynomial backtracking in terms of the input string length due to a Regular Expression in shescape that is vulnerable to Regular Expression Denial of Service (ReDoS). Example: Patches This bug has been patched in v1.6.1 which you can upgrade to now. No further changes required. Workarounds Alternatively, a maximum length can be enforced on input strings to shescape to reduce the impact of the vulnerability. It is not recommended to try and detect vulnerable input strings, as the logic for this may end up being vulnerable to ReDoS itself. References - Shescape commit 552e8ea - Shescape Release v1.6.1 For more information - Comment on commit 552e8ea - Open an issue at https://github.com/ericcornelissen/shescape/issues (New issue Question Get…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cr84-xvw4-qx3c
- Revision 1 · created ·
Published from osv record GHSA-cr84-xvw4-qx3c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25918 Advisory: Inefficient Regular Expression Complexity in shescape IDs: CVE-2022-25918, GHSA-cr84-xvw4-qx3c Record: https://patchnext.com/advisories/cve-2022-25918 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shescape 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm shescape: affected >= 1.5.10, < 1.6.1; fixed in 1.6.1 ## Suggested inspection (read-only) - `npm ls shescape --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shescape. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cr84-xvw4-qx3c (OSV record GHSA-cr84-xvw4-qx3c lists affected ranges: npm shescape >=1.5.10 <1.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-cr84-xvw4-qx3c (GitHub-reviewed advisory GHSA-cr84-xvw4-qx3c lists affected ranges: npm shescape >=1.5.10 <1.6.1) Commands are suggestions: review each one before running it.
Loading voting…