mt7688-wiscan is vulnerable to Command Injection due to improper input sanitization
CVE-2022-25916GHSA-5h8c-8ccp-8gmh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mt7688-wiscan 0.8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mt7688-wiscan
- Affected
- < 0.8.3
- Fixed in
- 0.8.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5h8c-8ccp-8gmh lists affected ranges: npm mt7688-wiscan >=0 <0.8.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h8c-8ccp-8gmh lists affected ranges: npm mt7688-wiscan >=0 <0.8.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-25916: 1.10% estimated exploitation activity in the next 30 days; percentile 65.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package mt7688-wiscan before 0.8.3 are vulnerable to Command Injection due to improper input sanitization in the 'wiscan.scan' function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5h8c-8ccp-8gmh
- Revision 1 · created ·
Published from osv record GHSA-5h8c-8ccp-8gmh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25916 Advisory: mt7688-wiscan is vulnerable to Command Injection due to improper input sanitization IDs: CVE-2022-25916, GHSA-5h8c-8ccp-8gmh Record: https://patchnext.com/advisories/cve-2022-25916 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mt7688-wiscan 0.8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mt7688-wiscan: affected < 0.8.3; fixed in 0.8.3 ## Suggested inspection (read-only) - `npm ls mt7688-wiscan --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mt7688-wiscan. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5h8c-8ccp-8gmh (OSV record GHSA-5h8c-8ccp-8gmh lists affected ranges: npm mt7688-wiscan >=0 <0.8.3 (fixed)) - Verified: https://github.com/advisories/GHSA-5h8c-8ccp-8gmh (GitHub-reviewed advisory GHSA-5h8c-8ccp-8gmh lists affected ranges: npm mt7688-wiscan >=0 <0.8.3) Commands are suggestions: review each one before running it.
Loading voting…