Skip to content

← Actionable
High, CVSS 8.6amended

JWS and JWT signature validation vulnerability with special characters

CVE-2022-25898GHSA-3fvg-4v2m-98jf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsrsasign 10.5.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jsrsasign

    Affected
    >= 4.8.0, < 10.5.25
    Fixed in
    10.5.25

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
  • CVE-2022-25898: 1.15% estimated exploitation activity in the next 30 days; percentile 67.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Jsrsasign supports JWS(JSON Web Signatures) and JWT(JSON Web Token) validation. However JWS or JWT signature with non Base64URL encoding special characters or number escaped characters may be validated as valid by mistake. For example, even if a string of non Base64URL encoding characters such as !@$% or \11 is inserted into a valid JWS or JWT signature value string, it will still be a valid JWS or JWT signature by mistake. When jsrsasign's JWS or JWT validation is used in OpenID connect or OAuth2, this vulnerability will affect to authentication or authorization. By our internal assessment, CVSS 3.1 score will be 8.6. CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N Patches Users validate JWS or JWT signatures should upgrade to 10.5.25. Workarounds Validate JWS or JWT signature if it has Base64URL and dot safe string before executing JWS.verify() or JWS.verifyJWT() method. ACKNOWLEDGEMENT Thanks to Adi Malyanker and Or David for this vulnerability report. Also thanks for Snyk…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3fvg-4v2m-98jf

  2. Revision 1 · created ·

    Published from osv record GHSA-3fvg-4v2m-98jf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25898

Advisory: JWS and JWT signature validation vulnerability with special characters
IDs: CVE-2022-25898, GHSA-3fvg-4v2m-98jf
Record: https://patchnext.com/advisories/cve-2022-25898 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jsrsasign 10.5.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jsrsasign: affected >= 4.8.0, < 10.5.25; fixed in 10.5.25

## Suggested inspection (read-only)
- `npm ls jsrsasign --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jsrsasign.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3fvg-4v2m-98jf (OSV record GHSA-3fvg-4v2m-98jf lists affected ranges: npm jsrsasign >=4.8.0 <10.5.25 (fixed))
- Verified: https://github.com/advisories/GHSA-3fvg-4v2m-98jf (GitHub-reviewed advisory GHSA-3fvg-4v2m-98jf lists affected ranges: npm jsrsasign >=4.8.0 <10.5.25)

Commands are suggestions: review each one before running it.

Loading voting…