Passport vulnerable to session regeneration when a users logs in or out
CVE-2022-25896GHSA-v923-w3x8-wh69
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (passport 0.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm passport
- Affected
- < 0.6.0
- Fixed in
- 0.6.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v923-w3x8-wh69 lists affected ranges: npm passport >=0 <0.6.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v923-w3x8-wh69 lists affected ranges: npm passport >=0 <0.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L
- EPSS
- CVE-2022-25896: 1.12% estimated exploitation activity in the next 30 days; percentile 66.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v923-w3x8-wh69
- Revision 1 · created ·
Published from osv record GHSA-v923-w3x8-wh69
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25896 Advisory: Passport vulnerable to session regeneration when a users logs in or out IDs: CVE-2022-25896, GHSA-v923-w3x8-wh69 Record: https://patchnext.com/advisories/cve-2022-25896 (revision 2, source checked 26 Oct 2026, 12:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: passport 0.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm passport: affected < 0.6.0; fixed in 0.6.0 ## Suggested inspection (read-only) - `npm ls passport --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on passport. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v923-w3x8-wh69 (OSV record GHSA-v923-w3x8-wh69 lists affected ranges: npm passport >=0 <0.6.0 (fixed)) - Verified: https://github.com/advisories/GHSA-v923-w3x8-wh69 (GitHub-reviewed advisory GHSA-v923-w3x8-wh69 lists affected ranges: npm passport >=0 <0.6.0) Commands are suggestions: review each one before running it.
Loading voting…