Server-Side Request Forgery in link-preview-js
CVE-2022-25876GHSA-h9cw-7g8j-h66h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (link-preview-js 2.1.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm link-preview-js
- Affected
- < 2.1.17
- Fixed in
- 2.1.17
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h9cw-7g8j-h66h lists affected ranges: npm link-preview-js >=0 <2.1.17 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h9cw-7g8j-h66h lists affected ranges: npm link-preview-js >=0 <2.1.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-25876: 0.37% estimated exploitation activity in the next 30 days; percentile 30.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package link-preview-js before 2.1.17 are vulnerable to Server-side Request Forgery (SSRF) which allows attackers to send arbitrary requests to the local network and read the response. This is due to flawed DNS rebinding protection.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h9cw-7g8j-h66h
- Revision 1 · created ·
Published from osv record GHSA-h9cw-7g8j-h66h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25876 Advisory: Server-Side Request Forgery in link-preview-js IDs: CVE-2022-25876, GHSA-h9cw-7g8j-h66h Record: https://patchnext.com/advisories/cve-2022-25876 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: link-preview-js 2.1.17. A vendor fix does not mean a deployment is fixed. ## Affected components - npm link-preview-js: affected < 2.1.17; fixed in 2.1.17 ## Suggested inspection (read-only) - `npm ls link-preview-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on link-preview-js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h9cw-7g8j-h66h (OSV record GHSA-h9cw-7g8j-h66h lists affected ranges: npm link-preview-js >=0 <2.1.17 (fixed)) - Verified: https://github.com/advisories/GHSA-h9cw-7g8j-h66h (GitHub-reviewed advisory GHSA-h9cw-7g8j-h66h lists affected ranges: npm link-preview-js >=0 <2.1.17) Commands are suggestions: review each one before running it.
Loading voting…