Unsanitized JavaScript code injection possible in gatsby-plugin-mdx
CVE-2022-25863GHSA-mj46-r4gr-5x83
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gatsby-plugin-mdx 3.15.2, 2.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.14.1>= 3.0.0, < 3.15.2
- Fixed in
- 3.15.2, 2.14.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mj46-r4gr-5x83 lists affected ranges: npm gatsby-plugin-mdx >=0 =3.0.0 <3.15.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mj46-r4gr-5x83 lists affected ranges: npm gatsby-plugin-mdx >=0 =3.0.0 <3.15.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-25863: 1.99% estimated exploitation activity in the next 30 days; percentile 80.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The gatsby-plugin-mdx plugin prior to versions 3.15.2 and 2.14.1 passes input through to the gray-matter npm package, which is vulnerable to JavaScript injection in its default configuration, unless input is sanitized. The vulnerability is present when passing input in both webpack (MDX files in src/pages or MDX file imported as component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Injected JavaScript executes in the context of the build server. To exploit this vulnerability untrusted/unsanitized input would need to be sourced or added into an MDX file. The following MDX payload demonstrates a vulnerable configuration: Patches A patch has been introduced in gatsby-plugin-mdx@3.15.2 and gatsby-plugin-mdx@2.14.1 which mitigates the issue by disabling the gray-matter JavaScript Frontmatter engine. The patch introduces a new option, JSFrontmatterEngine which is set to false by default. When setting JSFrontmatterEngine to true, input passed to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mj46-r4gr-5x83
- Revision 1 · created ·
Published from osv record GHSA-mj46-r4gr-5x83
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25863 Advisory: Unsanitized JavaScript code injection possible in gatsby-plugin-mdx IDs: CVE-2022-25863, GHSA-mj46-r4gr-5x83 Record: https://patchnext.com/advisories/cve-2022-25863 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gatsby-plugin-mdx 3.15.2, 2.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm gatsby-plugin-mdx: affected < 2.14.1; >= 3.0.0, < 3.15.2; fixed in 3.15.2, 2.14.1 ## Suggested inspection (read-only) - `npm ls gatsby-plugin-mdx --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gatsby-plugin-mdx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mj46-r4gr-5x83 (OSV record GHSA-mj46-r4gr-5x83 lists affected ranges: npm gatsby-plugin-mdx >=0 =3.0.0 <3.15.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mj46-r4gr-5x83 (GitHub-reviewed advisory GHSA-mj46-r4gr-5x83 lists affected ranges: npm gatsby-plugin-mdx >=0 =3.0.0 <3.15.2) Commands are suggestions: review each one before running it.
Loading voting…