Multi-Factor Authentication issue in Laravel Fortify
CVE-2022-25838GHSA-6w4v-qr4m-97gg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (laravel/fortify 1.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist laravel/fortify
- Affected
- < 1.11.1
- Fixed in
- 1.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6w4v-qr4m-97gg lists affected ranges: Packagist laravel/fortify >=0 <1.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-25838: 0.95% estimated exploitation activity in the next 30 days; percentile 61.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6w4v-qr4m-97gg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25838 Advisory: Multi-Factor Authentication issue in Laravel Fortify IDs: CVE-2022-25838, GHSA-6w4v-qr4m-97gg Record: https://patchnext.com/advisories/cve-2022-25838 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: laravel/fortify 1.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist laravel/fortify: affected < 1.11.1; fixed in 1.11.1 ## Suggested inspection (read-only) - Packagist laravel/fortify: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on laravel/fortify. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6w4v-qr4m-97gg (GitHub-reviewed advisory GHSA-6w4v-qr4m-97gg lists affected ranges: Packagist laravel/fortify >=0 <1.11.1) Commands are suggestions: review each one before running it.
Loading voting…