Skip to content

← Actionable
Medium, CVSS 6.5

Mautic: MST-48 Server-Side Request Forgery in Asset section

CVE-2022-25777GHSA-mgv8-w49f-822w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 5.0.4, 4.4.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mautic/core

    Affected
    >= 1.0.0-beta4, < 4.4.12>= 5.0.0-alpha, < 5.0.4
    Fixed in
    5.0.4, 4.4.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:H
EPSS
  • CVE-2022-25777: 0.45% estimated exploitation activity in the next 30 days; percentile 38.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Prior to the patched version, an authenticated user of Mautic could read system files and access the internal addresses of the application due to a Server-Side Request Forgery (SSRF) vulnerability. Patches Update to 4.4.12 or 5.0.4 Workarounds None References - https://owasp.org/Top10/A102021-Server-SideRequestForgery%28SSRF%29/ If you have any questions or comments about this advisory: Email us at security@mautic.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mgv8-w49f-822w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25777

Advisory: Mautic: MST-48 Server-Side Request Forgery in Asset section
IDs: CVE-2022-25777, GHSA-mgv8-w49f-822w
Record: https://patchnext.com/advisories/cve-2022-25777 (revision 1, source checked 26 Oct 2026, 14:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mautic/core 5.0.4, 4.4.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mautic/core: affected >= 1.0.0-beta4, < 4.4.12; >= 5.0.0-alpha, < 5.0.4; fixed in 5.0.4, 4.4.12

## Suggested inspection (read-only)
- Packagist mautic/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mautic/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mgv8-w49f-822w (GitHub-reviewed advisory GHSA-mgv8-w49f-822w lists affected ranges: Packagist mautic/core >=1.0.0-beta4 =5.0.0-alpha <5.0.4)

Commands are suggestions: review each one before running it.

Loading voting…