Mautic SQL Injection in dynamic Reports
CVE-2022-25775GHSA-jj6w-2cqg-7p94
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 5.0.4, 4.4.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- >= 2.14.1, < 4.4.12>= 5.0.0-alpha, < 5.0.4
- Fixed in
- 5.0.4, 4.4.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jj6w-2cqg-7p94 lists affected ranges: Packagist mautic/core >=2.14.1 =5.0.0-alpha <5.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-25775: 0.59% estimated exploitation activity in the next 30 days; percentile 48.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle. The user could retrieve and alter data like sensitive data, login, and depending on database permission the attacker can manipulate file systems. Patches Update to 4.4.12 or 5.0.4 Workarounds No References - https://owasp.org/www-community/attacks/SQLInjection - https://owasp.org/www-community/attacks/BlindSQLInjection
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jj6w-2cqg-7p94
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25775 Advisory: Mautic SQL Injection in dynamic Reports IDs: CVE-2022-25775, GHSA-jj6w-2cqg-7p94 Record: https://patchnext.com/advisories/cve-2022-25775 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 5.0.4, 4.4.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected >= 2.14.1, < 4.4.12; >= 5.0.0-alpha, < 5.0.4; fixed in 5.0.4, 4.4.12 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jj6w-2cqg-7p94 (GitHub-reviewed advisory GHSA-jj6w-2cqg-7p94 lists affected ranges: Packagist mautic/core >=2.14.1 =5.0.0-alpha <5.0.4) Commands are suggestions: review each one before running it.
Loading voting…