Improper regex in htaccess file
CVE-2022-25769GHSA-mj6m-246h-9w56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mautic/core 4.2.0, 3.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist mautic/core
- Affected
- < 3.3.5>= 4.0.0, < 4.2.0
- Fixed in
- 4.2.0, 3.3.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mj6m-246h-9w56 lists affected ranges: Packagist mautic/core >=0 =4.0.0 <4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2022-25769: 0.51% estimated exploitation activity in the next 30 days; percentile 43.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact the default .htaccess file has some restrictions in the access to PHP files to only allow specific PHP files to be executed in the root of the application. This logic isn't correct, as the regex in the second FilesMatch only checks the filename, not the full path. Patches Please upgrade to 3.3.5 or 4.2.0 Workarounds No References - Release post: https://www.mautic.org/blog/community/mautic-4-2-one-small-step-mautic - Internally tracked under MST-32 For more information If you have any questions or comments about this advisory: Email us at security@mautic.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mj6m-246h-9w56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25769 Advisory: Improper regex in htaccess file IDs: CVE-2022-25769, GHSA-mj6m-246h-9w56 Record: https://patchnext.com/advisories/cve-2022-25769 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mautic/core 4.2.0, 3.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist mautic/core: affected < 3.3.5; >= 4.0.0, < 4.2.0; fixed in 4.2.0, 3.3.5 ## Suggested inspection (read-only) - Packagist mautic/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mautic/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mj6m-246h-9w56 (GitHub-reviewed advisory GHSA-mj6m-246h-9w56 lists affected ranges: Packagist mautic/core >=0 =4.0.0 <4.2.0) Commands are suggestions: review each one before running it.
Loading voting…