Skip to content

← Actionable
High, CVSS 7.0amended

automattic/mongoose vulnerable to Prototype pollution via Schema.path

CVE-2022-2564GHSA-f825-f98c-gj3g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongoose 6.4.6, 5.13.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mongoose

    Affected
    >= 6.0.0, < 6.4.6< 5.13.15
    Fixed in
    5.13.15, 6.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
EPSS
  • CVE-2022-2564: 31.30% estimated exploitation activity in the next 30 days; percentile 98.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Affected versions of this package are vulnerable to Prototype Pollution. The Schema.path() function is vulnerable to prototype pollution when setting the schema object. This vulnerability allows modification of the Object prototype and could be manipulated into a Denial of Service (DoS) attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f825-f98c-gj3g

  2. Revision 1 · created ·

    Published from osv record GHSA-f825-f98c-gj3g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-2564

Advisory: automattic/mongoose vulnerable to Prototype pollution via Schema.path
IDs: CVE-2022-2564, GHSA-f825-f98c-gj3g
Record: https://patchnext.com/advisories/cve-2022-2564 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mongoose 6.4.6, 5.13.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mongoose: affected >= 6.0.0, < 6.4.6; < 5.13.15; fixed in 5.13.15, 6.4.6

## Suggested inspection (read-only)
- `npm ls mongoose --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mongoose.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f825-f98c-gj3g (OSV record GHSA-f825-f98c-gj3g lists affected ranges: npm mongoose >=6.0.0 =0 <5.13.15 (fixed))
- Verified: https://github.com/advisories/GHSA-f825-f98c-gj3g (GitHub-reviewed advisory GHSA-f825-f98c-gj3g lists affected ranges: npm mongoose >=6.0.0 =0 <5.13.15)

Commands are suggestions: review each one before running it.

Loading voting…