Appwrite Directory Traversal vulnerability
CVE-2022-25377GHSA-wfm3-gq9h-mrjm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (appwrite/server-ce 0.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist appwrite/server-ce
- Affected
- >= 0.5.0, < 0.12.2
- Fixed in
- 0.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wfm3-gq9h-mrjm lists affected ranges: Packagist appwrite/server-ce >=0.5.0 <0.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-25377: 0.79% estimated exploitation activity in the next 30 days; percentile 56.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../ directory traversal. In order to be vulnerable, APPSTORAGECERTIFICATES/.well-known/acme-challenge must exist on disk. (This pathname is automatically created if the user chooses to install Let's Encrypt certificates via Appwrite.)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wfm3-gq9h-mrjm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25377 Advisory: Appwrite Directory Traversal vulnerability IDs: CVE-2022-25377, GHSA-wfm3-gq9h-mrjm Record: https://patchnext.com/advisories/cve-2022-25377 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: appwrite/server-ce 0.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist appwrite/server-ce: affected >= 0.5.0, < 0.12.2; fixed in 0.12.2 ## Suggested inspection (read-only) - Packagist appwrite/server-ce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on appwrite/server-ce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wfm3-gq9h-mrjm (GitHub-reviewed advisory GHSA-wfm3-gq9h-mrjm lists affected ranges: Packagist appwrite/server-ce >=0.5.0 <0.12.2) Commands are suggestions: review each one before running it.
Loading voting…