EC-CUBE improperly handles HTTP Host header values
CVE-2022-25355GHSA-pw97-6v74-9w3p
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ec-cube/ec-cube
- Affected
- >= 3.0.0, <= 3.0.18-p3>= 4.0.0, <= 4.1.1
- Fixed in
- 4.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pw97-6v74-9w3p lists affected ranges: Packagist ec-cube/ec-cube >=3.0.0 =4.0.0 <=4.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-25355: 1.16% estimated exploitation activity in the next 30 days; percentile 67.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
EC-CUBE 3.0.0 to 3.0.18-p3 and EC-CUBE 4.0.0 to 4.1.1 improperly handle HTTP Host header values, which may lead a remote unauthenticated attacker to direct the vulnerable version of EC-CUBE to send an Email with some forged reissue-password URL to EC-CUBE users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pw97-6v74-9w3p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25355 Advisory: EC-CUBE improperly handles HTTP Host header values IDs: CVE-2022-25355, GHSA-pw97-6v74-9w3p Record: https://patchnext.com/advisories/cve-2022-25355 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: ec-cube/ec-cube 4.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ec-cube/ec-cube: affected >= 3.0.0, <= 3.0.18-p3; >= 4.0.0, <= 4.1.1; fixed in 4.1.2 ## Suggested inspection (read-only) - Packagist ec-cube/ec-cube: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ec-cube/ec-cube. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pw97-6v74-9w3p (GitHub-reviewed advisory GHSA-pw97-6v74-9w3p lists affected ranges: Packagist ec-cube/ec-cube >=3.0.0 =4.0.0 <=4.1.1) Commands are suggestions: review each one before running it.
Loading voting…