Skip to content

← Actionable
Critical, CVSS 9.8amended

Prototype Pollution in set-in

CVE-2022-25354GHSA-6956-83fg-5wc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (set-in 2.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm set-in

    Affected
    < 2.0.3
    Fixed in
    2.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-25354: 1.93% estimated exploitation activity in the next 30 days; percentile 80.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The package set-in before 2.0.3 is vulnerable to Prototype Pollution via the setIn method, as it allows an attacker to merge object prototypes into it. Note: This vulnerability derives from an incomplete fix of CVE-2020-28273

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-6956-83fg-5wc5

  2. Revision 1 · created ·

    Published from osv record GHSA-6956-83fg-5wc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25354

Advisory: Prototype Pollution in set-in
IDs: CVE-2022-25354, GHSA-6956-83fg-5wc5
Record: https://patchnext.com/advisories/cve-2022-25354 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: set-in 2.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm set-in: affected < 2.0.3; fixed in 2.0.3

## Suggested inspection (read-only)
- `npm ls set-in --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on set-in.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-6956-83fg-5wc5 (OSV record GHSA-6956-83fg-5wc5 lists affected ranges: npm set-in >=0 <2.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-6956-83fg-5wc5 (GitHub-reviewed advisory GHSA-6956-83fg-5wc5 lists affected ranges: npm set-in >=0 <2.0.3)

Commands are suggestions: review each one before running it.

Loading voting…