Skip to content

← Actionable
High, CVSS 7.5amended

Uncontrolled Resource Consumption in @discordjs/opus

CVE-2022-25345GHSA-rvgf-69j7-xh78

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@discordjs/opus 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-25345: 1.38% estimated exploitation activity in the next 30 days; percentile 72.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improperly handled errors in @discordjs/opus cause hard crashes instead of returning the error to user land. All versions of package @discordjs/opus (<= 0.7.0) are vulnerable to Denial of Service (DoS) when trying to encode using an encoder with zero channels, or a non-initialized buffer. This leads to a hard crash due to improperly returning the errors from the invalid inputs. As of version 0.8.0, the errors are correctly returned to the user and are no longer throwing hard crashes that cannot be recovered.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rvgf-69j7-xh78

  2. Revision 1 · created ·

    Published from osv record GHSA-rvgf-69j7-xh78

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25345

Advisory: Uncontrolled Resource Consumption in @discordjs/opus
IDs: CVE-2022-25345, GHSA-rvgf-69j7-xh78
Record: https://patchnext.com/advisories/cve-2022-25345 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @discordjs/opus 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @discordjs/opus: affected < 0.8.0; fixed in 0.8.0

## Suggested inspection (read-only)
- `npm ls @discordjs/opus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @discordjs/opus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rvgf-69j7-xh78 (OSV record GHSA-rvgf-69j7-xh78 lists affected ranges: npm @discordjs/opus >=0 <0.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rvgf-69j7-xh78 (GitHub-reviewed advisory GHSA-rvgf-69j7-xh78 lists affected ranges: npm @discordjs/opus >=0 <0.8.0)

Commands are suggestions: review each one before running it.

Loading voting…